Dynamic Fonts Are Antialiased Problem

JayBananaJayBanana Posts: 13Member

Hi,

I was following a tutorial which involved some text, it has Dynamic Fonts from a .TTF file. All works apart from the anti-aliasing can't be switched off, not ideal for a low-res retro game.

Is there a reason why the smoothing can't be switched off? Should I instead use bitmap fonts? On the latter, can anyone recommend a good up-to-date tutorial for creating bitmap fonts?

Cheers!

Answers

  • CalinouCalinou Posts: 217Admin Godot Developer

    Does the DynamicFont's size match the size the font designed for? It should be a multiple of the font's "design" size, otherwise, it's going to look blurry as in the screenshot.

    That said, in 3.1 beta, you can disable font anti-aliasing in DynamicFontData resources (make sure to save it as a .tres file afterwards, otherwise the anti-aliasing setting won't be preserved). It may solve your issue with the font being blurry, but it can also result in poor-looking fonts.

  • JayBananaJayBanana Posts: 13Member

    Thanks for the info, yes anti-aliasing can be switched off in 3.1. In version 3.0 it's always ant-aliased with Dynamic Fonts whatever the size as far as I'm aware - so I'm moving to Godot 3.1 Beta, it's the push I needed I guess.

  • JayBananaJayBanana Posts: 13Member
    edited February 5

    Well I thought all was well in 3.1 beta 3, but it isn't quite there!

    Even though you can turn off Anti-aliasing on the Dynamic font, it only appears to affect the editor/stage window. When you run the game, it comes back! Bug? Not sure :(

    Here's a screenshot...

    Can anyone else find a solution, or perhaps I should report it?

    Edit: After a little more experimenting, I've noticed that some fonts have the issue and some don't.

Sign In or Register to comment.