"INSTALL_FAILED_OLDER_SDK" error.

NeoDNeoD Posts: 148Member
edited January 23 in Exporting

Hi, I can't test my project on my Android phone. Godot version is 3.1 beta in GLES2 mode.

I guess the Android version is too old for the SDK used by Godot. This old phone's Android is stuck to 4.1.2 version.
After some searching I get some bits of info, the minimal Android version managed by the SDK can be set in some "build.gradle" or manifest file.
The Android SDK has many config files and I'm lost.
If you know which Godot file sets the minimal Android version, feel free to answer. Thanks in advance.

Tagged:

Tags :

Answers

  • NeoDNeoD Posts: 148Member
    edited January 23

    Here's the last lines of the console

    Failure [INSTALL_FAILED_OLDER_SDK]
    rm failed for -f, No such file or directory
    ** DEVICE API < 21; DEBUGGING OVER WI-FI **
    Starting: Intent `{ act=android.intent.action.MAIN cmp=com.neotry.snong/org.godotengine.godot.Godot }`
    Error type 3
    Error: Activity class `{com.neotry.snong/org.godotengine.godot.Godot}` does not exist.
    
  • NeoDNeoD Posts: 148Member
    edited January 23

    Sorry I can't paste the console lines. Here's the link to the Q&A

    https://godotengine.org/qa/39681/how-to-fix-android-install_failed_older_sdk-error

  • MegalomaniakMegalomaniak Posts: 1,087Admin
    edited January 23

    Problem with the paste was the curly brackets which have a special use in vanilla forums software, but I managed to fix that by editing your post and adding inline code formatting(``) to those bits.

Sign In or Register to comment.