FPS sits in a simple scene. What's the matter?

TorttortTorttort Posts: 16Member
in 3D

Comments

  • MagicLordMagicLord Posts: 578Unconfirmed
    edited March 4

    Did you use MeshInstance ? while i'm not sure it's real hardware instancing.
    Do you use a GI probe ? what anti aliasing ? And what environment post effects ?
    Godot does not have culling, this could be another reason

    For grass and alpha it's better to use specialized rendering and culling.

  • MegalomaniakMegalomaniak Posts: 998Admin
    edited March 5

    @MagicLord said:
    Did you use MeshInstance ? while i'm not sure it's real hardware instancing.

    MultiMesh.

    edit:
    Also this thread might be an interesting read:
    https://github.com/godotengine/godot/issues/14869

  • MagicLordMagicLord Posts: 578Unconfirmed

    Interesting read, it looks like 3.0.2 fixed something and now Godot is very fast for MultiMesh :)

    I just re-ran my project in 3.0.2 Stable and its blazing fast now. I didn't change any code, so something must have happened between the beta and stable release. Before it was consuming 100% of the gpu and large amounts of ram and cpu running at 5fps. Now it is hovering around 15% gpu usage and very little cpu and ram usage running at 60 fps. This can probably be closed now. Thank you for the hard work.

  • TorttortTorttort Posts: 16Member

    Did you use MeshInstance ?

    Yes

    Do you use a GI probe ?

    No

    what anti aliasing ?

    Disabled

    And what environment post effects ?

    AO enabled

    3.0.2 MeshInstance or MultiMesh is still 30 fps

  • MegalomaniakMegalomaniak Posts: 998Admin

    I suspect that you aren't using MultiMesh right.

  • MagicLordMagicLord Posts: 578Unconfirmed
    edited March 6

    @Torttort said:

    Did you use MeshInstance ?

    Yes

    Do you use a GI probe ?

    No

    what anti aliasing ?

    Disabled

    And what environment post effects ?

    AO enabled

    3.0.2 MeshInstance or MultiMesh is still 30 fps

    Your scene is running 50 to 60 fps on Windows, 1080p on a lower rig with a GTX960.

    Check your drivers or Unbutu or try 3.0.2.

  • TorttortTorttort Posts: 16Member

    Your scene is running 50 to 60 fps on Windows, 1080p on a lower rig with a GTX960.

    On a simple stage there should be 200-300 fps

    3.0.2 Multimesh example. There are no improvements.
    https://drive.google.com/file/d/16LOhd_doNrVS8JK8ijcxLz46U1uWWzJJ/view?usp=sharing

  • CalinouCalinou Posts: 193Admin Godot Developer
    edited March 7

    AO enabled

    AO is currently slow because it's rendered at full resolution. It could be made to render at half resolution like in most other engines, but since the renderer will eventually move from OpenGL ES 3.0 to Vulkan, this may not be done soon unless someone contributes it.

  • MagicLordMagicLord Posts: 578Unconfirmed
    edited March 7

    @Torttort said:

    Your scene is running 50 to 60 fps on Windows, 1080p on a lower rig with a GTX960.

    On a simple stage there should be 200-300 fps

    3.0.2 Multimesh example. There are no improvements.
    https://drive.google.com/file/d/16LOhd_doNrVS8JK8ijcxLz46U1uWWzJJ/view?usp=sharing

    Update : My test was with 3.0.2 same result 50 to 60 fps.
    Does Godot have some caped value somewhere not allowing to run higher than 60 fps ?

    @Calinou said:

    AO enabled

    AO is currently slow because it's rendered at full resolution. It could be made to render at half resolution like in most other engines, but since the renderer will eventually move from OpenGL ES 3.0 to Vulkan, this may not be done soon unless someone contributes it.

    I disabled SSAO from post effects, the results are the same.

Sign In or Register to comment.