Getting blurring/antialiasing with filters and mipmapping turned off.

EulersIdentityEulersIdentity Posts: 2Member

I was getting clear textures before, and now without changing any settings, they are showing up with blurring. The base image for this tileset is has only dark green, light green, and alpha, so I shouldn't have intermediate green values.

Here's my settings:

Here's the base image:

And here's what I'm getting in Godot:

This is at 1:1 scale, and it stays the same regardless of resizing.

These are 16x16 tiles that I've zoomed in on.

By comparison, my mockup character and fonts are showing up correctly using the same settings:

The whole project is at https://github.com/Ach-Fusco/Test_Project

The scene in question is res://test.tscn and I put the image I used to import from as "res://Green Landscape.png"

Thanks for any help you can give.

Answers

  • TwistedTwiglegTwistedTwigleg Posts: 94Member

    You don't need to import the texture for use in Godot, you can just load the .PNG file.

    If you want to import the texture without the blur, then you need to select "No MipMaps" and "Fix Border Alpha" and it will not be blurry anymore.

    I'd highly suggest just using the .PNG file though, it's easier and reduces duplicate files :smiley:

Sign In or Register to comment.