How does one scale the Godot App on a Macbook Pro using a larger second monitor?

jfiorellojfiorello Posts: 2Member

I am just starting with Godot on a Macbook Pro and I'm trying to use it on a second LG 35" monitor. The problem is the engine works fine on the laptop's screen but when I drag it to the larger monitor the window for the engine becomes magnified and won't resize and becomes unusable. I can use it on the smaller laptop screen just fine but I would really like it on the larger second screen so I can see it better.

Answers

  • CalinouCalinou Posts: 63Member Godot Developer

    Godot 2.1 doesn't support scaling the editor window when moving it between displays with different DPI values. If you are using the editor only on the loDPI display, you can force Godot to use loDPI by opening the Editor Settings, then choosing the Global section, then setting Hidpi Mode to loDPI. This requires a restart of the editor to take effect; note that this will make the editor appear as tiny on the laptop display (but it should be fine on the external monitor).

    Note that Godot 3.0 should hopefully support moving the editor window between displays with different DPI values.

  • jfiorellojfiorello Posts: 2Member

    Thank you for the reply. I tried your suggestion but it did not work. However, after I tried closing the lid on my MacBook Pro to cause my second monitor to become my primary monitor the editor scaled just fine. The downside is I cannot use the laptop display for anything (like tutorials) but this solution will do until hopefully Godot 3.0 supports switching between displays.

Sign In or Register to comment.