can't see label or viewport lines in 2d scene editor

gibberingmouthergibberingmouther Posts: 11Member

i'm just starting with Godot, so trying to go through the tutorials. i started here: http://docs.godotengine.org/en/stable/tutorials/step_by_step/scenes_and_nodes.html

i have no problem adding a label to the scene and moving it around. i zoomed out to maximum and i can't see the label when i run the scene, even though it is right in the center. i tried moving it around and fiddling with the properties but no matter what i do i can't get it visible when i run the scene.

i'm also supposed to have lines showing the viewport but i see nothing no matter where i zoom in to or out. here's a picture: https://postimg.org/image/m0ei5cirf/

Answers

  • RossRoss Posts: 199Member

    That's pretty weird. Did you download the official version from the website?

  • @Ross said:
    That's pretty weird. Did you download the official version from the website?

    yes. and Godot is not shown in my control panel's programs and features so i'd have to uninstall it manually somehow to reinstall it, which i don't know how to do. ugh....

  • RossRoss Posts: 199Member

    Godot is only one file, you can just download it again and start that version. Don't know what else to try though, sorry. I've never had issues like that. You could try searching the github and Q&A for other people with the same issue, or post your OS and issue in the IRC or discord chat.

  • gibberingmouthergibberingmouther Posts: 11Member
    Answer ✓

    tried reinstalling, didn't work. i installed Godot on my other, 64 bit laptop, and it seems to work fine now. so i guess i'll just wait and see if newer versions will work on my preferred game dev. laptop.

  • RossRoss Posts: 199Member

    Ah. Well if you report the issue on github it's much more likely to get fixed. https://github.com/godotengine/godot/issues

    Or you can try a newer version yourself, from https://archive.hugo.pro/godot/ or http://fixnum.org/godot/

  • gibberingmouthergibberingmouther Posts: 11Member
    edited November 2016

    also i now have a rectangular select when i click and move the mouse. in my other laptop's Godot this was invisible.

    edit: okay, i reported the error on Github! thank you for instructing me to do that

Sign In or Register to comment.